Active Query Builder support area

Visual Studio 2012, QueryBuilderControl_Init never fires

  • updated
  • Completed

Using AQB 1.05, I am able to build a working demo in Visual Studio 2010, under .Net 4.0.  However, under VS 2012 (also targeting .Net 4.0) the control never populates.  It appears that the _Init never fires.

I've set up the AQB components both manually and using NuGet.  No difference.  No exceptions are thrown, and no JS errors in the console.  This is perplexing.  Any insight is appreciated.

Andrey Zavyalov, PM


We need more information about your problem. What is your development environment (classic ASP.NET, MVC or MVC with Razor), what are the paths to ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Control and ActiveDatabaseSoftware.ActiveQueryBuilder.Web.Server assemblies in the Project References?

Have you tried to open the demo projects that included in the installation package? We checked all of them in Visual Studio 2012 and found no problems. Do they work for you? If they work, please try to find the difference between one of them and your project. If you can't find it, please send us your demo project in which this problem could be reproduced.


Thanks for the quick response.

Classic ASP.Net.  Paths point to the installation from NuGet  (D:\Program Files\ActiveDBSoft\Active Query Builder ASP.NET Trial Edition\assemblies\.NET 2.0\.......)

There are no projects included with the NuGet installation package as far as I can tell.  There are loose files (...\web-parts\!C#, for example) but there is no project or solution file binding them together, without which the problem of implementation errors on my end creeps back in.  Is there somewhere else I should be looking?

FYI -- I created an ASP.Net web project from the pieces in \web-parts.  Right off the bat, using the web.config included in the ADB installation, VS 2012 and IIS Express throws this  (which I've seen and corrected during other tests).  What exactly is the target environment under VS 2012 that I should be using?  Out of the box settings don't appear to work with the web.config you've included, which makes me wonder what else is out of sync with your target environment.  Thanks.

HTTP Error 500.22 - Internal Server Error

An ASP.NET setting has been detected that does not apply in Integrated managed pipeline mode.

Most likely causes:

  • This application defines configuration in the system.web/httpModules section.

Things you can try:

  • Migrate the configuration to the system.webServer/modules section. You can do so manually or by using AppCmd from the command line. For example, from the IIS Express install directory, runappcmd migrate config "Default Web Site/". Using AppCmd to migrate your application will enable it to work in Integrated mode. It will continue to work in Classic mode and on previous versions of IIS.
  • If you are certain that it is OK to ignore this error, it can be disabled by setting system.webServer/validation@validateIntegratedModeConfiguration to false.
  • Alternatively, switch the application to a Classic mode application pool. For example, from the IIS Express install directory, runappcmd set app "Default Web Site/" /applicationPool:"Clr4ClassicAppPool". Only do this if you are unable to migrate your application.

Andrey Zavyalov, PM

Have a look for the demo projects in the "%USERPROFILE%\Documents\Active Query Builder ASP.NET Examples" folder. If there's no such folder, please download the trial version from the download page on our web site. 

Have a look at the Quick Start Guide for classic ASP.NET environment. In the Step 3 you will find different settings for IIS 6 and IIS 7, try to use IIS 7 settings instead of IIS 6.

Anyway, you still can send us your demo project for investigation.


Clearly I've goofed.  I started from absolute scratch and built a .Net 2.0 in 2012 (worked) and a .Net 4.0  in 2012 (also worked).  Obviously I either configured something incorrectly or I have a conflict somewhere in my larger app, but AQB is doing what it's supposed to in the clean version.  Thank you for your patience!