No schema shown for ProvideX database

Answered

Comments

4 comments

  • Avatar
    JLathem


    I want to add something else that I've discovered.  If I manually type in a valid SQL Query, the visual designer portion does show the Tables with all fields.  It's only the Schema tree that is blank.  Thanks!

    0
    Comment actions Permalink
  • Avatar
    Sergey Smagin (Product manager)

    Hello,


    Possibly your ODBC driver doesn't implement the necessary functions to retrieve database schema information and your database server doesn't have the INFORMATION_SCHEMA.* tables or their structure differs from the standard. In this case you can load metadata programmatically. Have a look at the Load Metadata demo project that's included in the installation package, review the articles of the Knowledge Book:


    for AQB. 2 NET: Adding objects to the Metadata Container programmatically

    for other editions: Loading metadata programmatically

    0
    Comment actions Permalink
  • Avatar
    JLathem


    Thanks for the info.  I ended up going with the dynamic method using the

    ItemMetadataLoading event and it works great.  I set the Schema node to 'Default' so the QueryBuilder doesn't include it in the SQL statements.

     

    0
    Comment actions Permalink
  • Avatar
    Sergey Smagin (Product manager)

    Possibly your ODBC driver doesn't implement the necessary functions to retrieve database schema information and your database server doesn't have the INFORMATION_SCHEMA.* tables or their structure differs from the standard. In this case you can load metadata programmatically. Have a look at the Load Metadata demo project that's included in the installation package, review the articles of the Knowledge Book:

    for AQB. 2 NET: Adding objects to the Metadata Container programmatically

    for other editions: Loading metadata programmatically

    0
    Comment actions Permalink

Please sign in to leave a comment.