Add Link Objects leaves drop shadow

Completed

Comments

9 comments

  • Hello,

    Different popup menu objects can leave this shadow. This is known problem, but it looks like a bug in VCL or something like that. We can't impact on this shadow in any way. Sorry.

    0
    Comment actions Permalink
  • Avatar
    Minieggs

    Does the suggestion on here help ?

    http://qc.embarcadero.com/wc/qcmain.aspx?d=53384

    I personally don't think that particular tool tip adds very much information. Could it simply be removed ?

    Thanks

    0
    Comment actions Permalink
  • Avatar
    Minieggs

    Actually how do you add a linked object ? I can't seem to make this feature work or find anything in the help document

    I'm obviously missing something obvious

    It just keeps saying no objects

    0
    Comment actions Permalink
  • Hello,

    This shadow isn't from a tooltip, it's from the popup menu, so your suggestion won't help.

    If there's no foreign keys in your database, there'll be no suggestions for linked objects. You can add some constraints to the Metadata Container programmatically. Or may be you want to hide that button?

    0
    Comment actions Permalink
  • Avatar
    Minieggs

    Yes hiding the chain link button would be good as the relationships and business rule are not stored in the SQL database

    0
    Comment actions Permalink
  • Ok, we'll do this. But please note that you can add business rules to the metadata container by yourself, so user will see related objects, and objects will be joined automatically: this will ease the query building process.

    0
    Comment actions Permalink
  • Avatar
    Minieggs

    Thanks very much for considering this. You point about adding business rules to the metadata is noted. Thanks

    0
    Comment actions Permalink
  • Avatar
    Minieggs

    I've just tried a DF version of the code on this page

    http://www.activedbsoft.com/helpdesk/index.php?pg=kb.page&id=41

    It worked and auto created the relationship between the two tables and when dragged them into the design area

    When I click on the link chain the child table was shown and clicking on it brought another copy of it onto the design view linked to the parent

    The drop shadow is still left behind after use

    So I think the option to remove the link in the first place is better (for us .... but I appreciate we are not your only client!!)

    0
    Comment actions Permalink
  • Set the ShowLinkedObjectsButton property to false to hide that button.

    0
    Comment actions Permalink

Please sign in to leave a comment.