Delete foreign key relation not working in design area

Answered

Comments

6 comments

  • Avatar
    Sergey Smagin (Product manager)

    Hello, 

    We can't reproduce this problem on the latest version. Please update your version to the latest.

    0
    Comment actions Permalink
  • Avatar
    Gopichand

    Now i have updated ActiveQueryBuilder2 to latest version 2.10.10.815. Still i have this issue. Below are the steps to reproduce it.

    1) Drag tables which have foreign key relation ship

    2) Click on "Execute query" button which will navigate to "Query Results" tab.

    3) Come back to Query Builder tab and try deleting the relation it will appear again.

    4) Not only relation try removing the table by clicking close(x) icon it appears again.

    0
    Comment actions Permalink
  • Avatar
    Sergey Smagin (Product manager)

    Hi,

    Thank you for the steps to reproduce.

    I was able to reproduce the problem down to the third point. The link re-appears only after the linked table is moved. I am writing this to ensure that we are on the same page.

    I am kindly asking you to do the following: open the browser dev.tools (F12), go to the network tab, set the filter to JS files and refresh the web page. Find the usr_v2_***.js file and tell me its full name.

    0
    Comment actions Permalink
  • Avatar
    Gopichand

    Hi,

    Full name of the file is usr_v2_13_15.js. Browser am using is Google Chrome with version as Version 60.0.3112.113 (Official Build) (64-bit).

    Now i see that link re-appears if i move the table too. Even without moving also it re-appears for first time.

    It seems like the first action deleting a relation and removing a table from Query Designer after coming back from Query Results tab to Query Builder is not working.

    0
    Comment actions Permalink
  • Avatar
    Sergey Smagin (Product manager)

    I confirm that I was able to reproduce the problem down to the third point. The link re-appears only after the linked table is moved. We will fix this in the next version.

    I can not reproduce the fourth point (re-appearing of a table). A screencast might be helpful.

    Anyway, please note that even the link re-appears, the query text remains correct. 

    0
    Comment actions Permalink
  • Avatar
    Sergey Smagin (Product manager)

    Hello,

    Please download the new version and let us know if the problem is fixed on your side.

    0
    Comment actions Permalink

Please sign in to leave a comment.